Fork me on GitHub

Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 16
Number of dependencies (NOD): 48
Number of unique artifacts (NOA): 52
Number of version-conflicting artifacts (NOC): 2
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 92 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

mysql:mysql-connector-java

[Error]
8.0.28
  1. com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1
    \- mysql:mysql-connector-java:jar:8.0.28:compile

  2. com.kohlschutter.junixsocket:junixsocket-dist:pom:2.5.1
    \- com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1:compile
       \- mysql:mysql-connector-java:jar:8.0.28:compile

8.0.29
  1. com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1
    \- com.kohlschutter.junixsocket:junixsocket-mysql:jar:2.5.1:compile
       \- mysql:mysql-connector-java:jar:8.0.29:provided

  2. com.kohlschutter.junixsocket:junixsocket-dist:pom:2.5.1
    \- com.kohlschutter.junixsocket:junixsocket-mysql:jar:2.5.1:compile
       \- mysql:mysql-connector-java:jar:8.0.29:compile

org.jetbrains.kotlin:kotlin-stdlib

[Error]
1.4.0
  1. com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1
    \- com.squareup.okhttp3:okhttp:jar:4.9.3:compile
       \- com.squareup.okio:okio:jar:2.8.0:compile
          \- org.jetbrains.kotlin:kotlin-stdlib:jar:1.4.0:compile

  2. com.kohlschutter.junixsocket:junixsocket-dist:pom:2.5.1
    \- com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1:compile
       \- com.squareup.okhttp3:okhttp:jar:4.9.3:compile
          \- com.squareup.okio:okio:jar:2.8.0:compile
             \- org.jetbrains.kotlin:kotlin-stdlib:jar:1.4.0:compile

  3. com.kohlschutter.junixsocket:junixsocket-jetty:jar:2.5.1
    \- com.squareup.okhttp3:okhttp:jar:4.9.3:test
       \- com.squareup.okio:okio:jar:2.8.0:test
          \- org.jetbrains.kotlin:kotlin-stdlib:jar:1.4.0:test

1.4.10
  1. com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1
    \- com.squareup.okhttp3:okhttp:jar:4.9.3:compile
       \- org.jetbrains.kotlin:kotlin-stdlib:jar:1.4.10:compile

  2. com.kohlschutter.junixsocket:junixsocket-dist:pom:2.5.1
    \- com.kohlschutter.junixsocket:junixsocket-demo:jar:2.5.1:compile
       \- com.squareup.okhttp3:okhttp:jar:4.9.3:compile
          \- org.jetbrains.kotlin:kotlin-stdlib:jar:1.4.10:compile

  3. com.kohlschutter.junixsocket:junixsocket-jetty:jar:2.5.1
    \- com.squareup.okhttp3:okhttp:jar:4.9.3:test
       \- org.jetbrains.kotlin:kotlin-stdlib:jar:1.4.10:test